quaderns

bitàcola de l'ies emili darder|web instituto | Contacto

Dificultades de XHTML estricto en el post anterior

webdarder | 16 Agost, 2004 20:59

En el post anterior: Textos: sus códigos principales, la validación de XHTML estricto me daba error por la causa siguiente:

Los ejemplos de código para que se vieran en pantalla como texto entre las etiquetas code los ponía dentro de un divisor con un id="anuncio" que en pantalla se ve con un fondo amarillo y que había utilizado en algunas páginas sin haber tenido dificultades en la validación del XHTML.

Bien, pues esta vez, en la página aparecían cuatro div id="anuncio" y el validador me indicaba error debido a que sólo podía poner uno. Y si quería utilizar varios tenía que ponerlos en forma de class.

Así que he tenido que estudiar un poco el tema y modificar el CSS

El div="anuncio", que presenta fondo amarillo, no lo he tocado y sigue igual que antes:

#anuncio {
border-right : 1px solid #444;
padding-right : 5px;
border-top : 1px solid #ff8;
display : block;
padding-left : 5px;
font-size : 14px;
right : 0;
left : 100px;
padding-bottom : 5px;
border-left : 1px solid #ff8;
width : 350px;
color : #333333;
bottom : 0;
padding-top : 5px;
border-bottom : 1px solid #444;
font-family : "Comic Sans MS";
position : relative;
top : auto;
height : auto;
background-color : #ffffcc;
text-align : center;
}

He añadido al CSS un div class="letreros", de fondo azul y cuyo código es:

.letreros {
border-right : 1px solid #444;
padding-right : 5px;
border-top : 1px solid #ff8;
display : block;
padding-left : 5px;
font-size : 14px;
right : 0;
left : 100px;
padding-bottom : 5px;
border-left : 1px solid #ff8;
width : 350px;
color : #333333;
bottom : 0;
padding-top : 5px;
border-bottom : 1px solid #444;
position : relative;
top : auto;
height : auto;
background-color : #66ccff;
text-align : left;
}

En una página puedo poner varios div class="letreros", pero sólo puedo poner un div id="anuncio". Ahora, el validador de XHTML estricto para esa página me da válido.

No me ocurre lo mismo con el validador del CSS que, como antes de realizarse el cambio en los blocs, vuelve a darme error sólo en la línea 0. Lo cual no entiendo.

 
Accessible and Valid XHTML 1.0 Strict and CSS
Powered by LifeType - Design by BalearWeb